Problem with solving the reinforced concrete beam

  • 49 Views
  • Last Post 02 July 2018
  • Topic Is Solved
Joseph Lim posted this 02 July 2018

Dear community, 

 

I was trying to solve the reinforced concrete beam using the element commands tools (for concrete and reinforcement). However, after I run the analysis, the following error occurs:

i)  Material properties may only contain 100 data values. 

The starting position for material EX is 200000 which is outside this range. The MPDATA command is ignored. 

 

when using the command below:

Similar commands in the modelling folder.

 

ii) Constraint equation 1 has unused node 10652.                           

when using the command below:

et,matid,solid65

MP,Ex,matid,1500

MP,Prxy,matid,0.2

MP,Dens,matid,2400e-9

TB,concr,matid

tbdata,1,0.3,1,0.304,4.278

Do you have an idea? Thank you very much in advance for your help and time. 

Attached Files

Order By: Standard | Newest | Votes
AnPham posted this 02 July 2018

Hi Lim,

I see an issue in your code defining Material Properties on LineBody:

MPDATA,EX,MATID,2e5

Syntax for MPDATA command: MPDATA, Lab, MAT, SLOC, C1, C2, C3, C4, C5, C6

with SLOC is Starting location in table for generating data.

For Young's Modulus property, it's only contain 100 data values. So, when you define SLOC=2e5, which is outside this range.

Recommend: use MP,EX command instead of MPDATA command

  • Liked by
  • Joseph Lim
AnPham posted this 02 July 2018

For second problem, please use option: Element order = Linear (dropped) in Mesh setting

  • Liked by
  • Joseph Lim
Joseph Lim posted this 02 July 2018

Hi AnPham,

Thank you very much for the reply! It helps me to solve the problem related to command. 

 

However, I realised that the load vs deflection curve is directly proportional, which I was not able to identify the ultimate load. Do you have any suggestions for this problem?

Thank you very much in advance. 

 

Regards

Lim 

Close