Refine elements along edge in ACP

  • 111 Views
  • Last Post 21 November 2018
csup26 posted this 20 November 2018

I generated a solid model of my geometry and the elements along the sharp curve look very coarse. Shown in the image below is the "wavy" edge that it appearing in the solid model. My mesh in Mechanical is a fine mesh at that point but ACP shows a different mesh. How can I refine these elements to create a smoother surface?

Order By: Standard | Newest | Votes
apwang posted this 21 November 2018

Hi,

Can you turn on mesh plot in ACP to show the mesh? This way we have a better view of the problem.

I made a simple test with an elliptical hollow tube, which looks alright, see below image. 

Any specific procedure you made for the model? 

Another thing you might want to consider is to use "Snap to Geometries" when creating Solid Models, which will snap the composites to an imported geometry. This is useful when the automatically generated composites surface is not smooth enough. You can refer to Workshop problem 8 (Solid_Modeling_and_Ply_Drop_Offs) in Composites Training Material for the usage of "Snap to Geometries."

 

Regards,

April

 

 

 

csup26 posted this 21 November 2018

Here is my current mesh:

 

I can try Snap to Geometries and see if that helps. I am assuming this problem would go away if I refined the mesh at this point further in Mechanical but I am already well above my node and element limit. Not sure what to do at this point.

To create the model, I laid plies on the outside of a shell, stacking outward, and used geometry cut off to create the correct outside shape. 

I am using Material Wise extrusion method in the solid model.

Close