Rigid body meshing error

  • 83 Views
  • Last Post 27 February 2020
MargretSR posted this 26 February 2020

I have an assembly in a static structural study. When all parts were flexible, the model ran just fine, but to decrease simulation time I redefined some parts as rigid. I updated the contacts between the rigid parts and the flexible parts, making sure the rigid parts were the Target side and the flexible parts the Contact side. 

When I solve the simulation now, I get these errors shown in the images below: 

"Rigid bodies scoped to contacts will require remeshing to solve successfully, but cannot be meshed because meshing is blocked."

Does anyone know why this meshing error appears and how can I fix it?

Best regards,

Margret

Order By: Standard | Newest | Votes
peteroznewman posted this 27 February 2020

I don't have experience with ACP Pre.  Maybe you can't use Rigid bodies in the combination you want. I don't know for sure.

MargretSR posted this 27 February 2020

There is no generated mesh to clear.

The structure of my workbench is I have one Mechanical model where I load in steel parts I need for my analysis but I defined them rigid there. Then I have one ACP Pre where I have a part made from composites and I generate a solid model there. These two components are then imported into a static structural component, when I try to solve that, then I get these errors but there is no existing mesh there that I can clear as you suggest. 

peteroznewman posted this 26 February 2020

Right click on Mesh and Clear Generated Data.  Then right click on Mesh and Generate Mesh.

  • Liked by
  • MargretSR
Close