Running an explicit dynamics simulation on a composite plate

  • 1.1K Views
  • Last Post 29 March 2019
  • Topic Is Solved
niauj posted this 18 July 2018

Hello everyone,

 

I am currently trying to compute the transient response of a composite plate submitted to a variable force.

I successfully created my composite shell model setup using an ACP (Pre) component (see the picture). I was able to use it in a modal analysis, so I guess this part is working fine.

However, when I import this setup in an Explicit Dynamic module  and click "solve", I get the following error message in the solver's output :

"Retrieving Parts Data .....Error! Material with invalid equation of state assigned to surface body."

I also tried to assign a homogenous material to the shell to check if the problem was not due to the solver's settings, but it just worked fine.

 

Any suggestion to fix this?

Thanks in advance,

 

Nicolas

 

Attached Files

Order By: Standard | Newest | Votes
ssridhar posted this 18 July 2018

Hi Nicolas,

Are you defining a new material in Engineering data of ACP Pre with custom material properties for the analysis?  If so what properties are you including in the definition ( Orthotropic elasticity, failure, EOS) etc. ?

A snapshot of the Engineering data would work great as a starting point to see how to proceed further. 

Sincerely,

Raghav

niauj posted this 18 July 2018

Hi Raghav,

Thank you for your answer!

I am not using a custom material, I am using the Epoxy-Carbon unidirectionnal (230 GPa) defined in "Engineering data sources" -> Composite materials (see the snapshot attached to the post). I did not modify any value, so I think all the fields are filled in with the appropriate values.

Regards,

Nicolas

 

PS : sorry, Ansys is installed in French in my computer...

 

Attached Files

ssridhar posted this 19 July 2018

Hi Nicolas,

Thank you for sending this information. I tried a simple drop test using the same material and was able to bring in the ACP model into Explicit Dynamics and run successfully. I see you have mentioned that you are using Composite shell body for analysis. Can you re-check if you are transferring only the Shell composite data to the Explicit Dynamic system and not the Solid composite model? Explicit dynamics does not support solid composite layups.

Also, do you have other parts in your model (composite/non-composite)? You may want to check the material properties of the same before import. Take a look at the Explicit material library with Workbench Engineering Data sources. 

I am afraid I have not encountered this issue before. Maybe someone in the forum with more experience in this domain can comment. 

Sincerely,

Raghav

  • Liked by
  • Jackely
sharvey posted this 19 July 2018

Hi Nicolas,

I have just tested using 19.1 and the same material as you with a 4 ply stackup of a plate fixed on edges and a step applied pressure and the solver starts. There are no other parts or regions. It is just a single surface for this simple test.  Do you have multiple parts/bodies? I will also ask one of my colleagues who knows explicit to see what else it could be.  Thank you.

 

Sean

niauj posted this 19 July 2018

Hi Raghav,

Thanks again for your reactivity.

I am indeed using a shell body, because I was aware of this incompatibility between solid bodies in ACP and explicit dynamics. I tried with a solid body out of curiosity, and I get a different error message. My model does not have another part, it is simply composed of the plate.

Thanks anyway for your help. Hopefully, someone who faced the same problem could help me.

Regards,

 

Nicolas

 

 

 

niauj posted this 19 July 2018

Hi Sean,

As I said in my answer to Raghav, there is no other part. My composite model is exactly the same as yours (4 ply stackup, all at 0 degree orientation).

Could it be because of the ANSYS version I use? (I am using the version 18.1)

Thank you,

Nicolas

 

ssridhar posted this 19 July 2018

Hi Nicolas,

Please try importing the model into Workbench-LSDyna analysis system as well.

 

Sincerely,

Raghav

sharvey posted this 19 July 2018

Hi Nicolas,

It should not be as in the past this has worked in multiple prior releases. Let me see what our explicit expert has to say.  Thank you.


Sean

SandeepMedikonda posted this 19 July 2018

Hello Nicolas,

  There is something not right here, when you drag and drop the external dynamics system on the Setup cell of the ACP, it should look something like as shown below:

Are you linking the cells separately? Can you please confirm and try this way if not?

~Sandeep

sharvey posted this 19 July 2018

Hi Nicolas,

Just to clarify what Sandeep posted.  The single line linking is the newer workflow and the connection of each cell  where we drag and drop explicit dynamics onto ACP and connect all the cells down to setup - > Model is the original workflow.  Please do try the older workflow and see if it changes the outcome.

 

Thank you

Sean

niauj posted this 19 July 2018

 Hello Sandeep,

I hope I understood what you suggested. Here is the new workflow I've been testing :

Is it the correct architecture?

I tried it with the exact same configuration, and I still get the same Error.

Thanks,

 

Nicolas

 

SandeepMedikonda posted this 19 July 2018

Nicolas, You've probably checked this already but can you confirm if you are seeing the correct material assignments under geometry? 

niauj posted this 19 July 2018

The material assignments seems to be correctly set. Under Geometry, "Composite Material" is set (see zone 2 in the image below).

As well, all the plies seem to be successfully imported (see zone 1 in the image below).

Thank you again,

 

Nicolas

 

 

SandeepMedikonda posted this 19 July 2018

Nicolas,

Can you suppress each item at a time (for example, Tsai-Wu constants, Orthotropic Strain Limits, Orthotropic Stress Limits, Orthotropic Thermal Expansion, etc), then update the system and solve to see which item is causing the error message?

This should help in identifying the problem as some features such as Tsai-Wu failure model are available in Autodyn GUI and not in the Explicit Dynamics system.

~Sandeep

  • Liked by
  • niauj
  • marilyne16
niauj posted this 19 July 2018

It worked!

I just deleted the Tsai-Wu constants from the Engineering Data, and the solver started immediatly!

Thank you so much for your time,

 

Nicolas

marilyne16 posted this 22 January 2019

Hi Sandeep,

I have a similar problem, I tried to suppress Tsai-Wu constants, Orthotropic Strain Limits, Orthotropic Stress Limits, Orthotropic Thermal Expansion, but I still get the error "Material with invalid equation of state". I transfer my composite plate made from ACP to an Explicit Dynamics analysis with shell.

I created an impactor in mechanical model for a drop impact test, that I added in Explicit Dynamics. Any idea why I still have the error?

Thanks,

Marilyne

SONAM posted this 31 January 2019

hello sir,

I am so trying to solve bearing strength of natural fibers composite materials by using ANSYS software. Can u plz suggest me

SONAM posted this 29 March 2019

how to solve this problem? plz suggest me...

Close