Runtime errors on Centos 7 system

  • 1.3K Views
  • Last Post 07 November 2018
yatcilla@purdue.edu posted this 24 September 2018

I installed ANSYS 19.1 on a Centos 7 system. I can start Workbench with "runwb2" without problems,

But, then starting DesignModeler results in "Microsoft JScript runtime error".  Also, trying to start Mesh results in "failed determining temp directory location"  More info at:

I notice the same problems with ANSYS versions 19.2 & 18.2

I don't see the problems when I try ANSYS on a Red Hat Linux version 6 system.

Order By: Standard | Newest | Votes
pgl posted this 24 September 2018

Hi yatcilla,  

Are you installing the free ANSYS Student product, or are your using a paid for Teaching or Research license here?

Things to check:

  • Our Student Products are not supported on CentOS, they are Microsoft Windows only. 
  • For our Teaching & Research products, make sure you are using a supported version of CentOS. The first version of CentOS that we support is CentOS 7.2 at Release 18.0. See here for our supported platforms. 

Also see this post. 

yatcilla@purdue.edu posted this 24 September 2018

This is not the free ANSYS student product.  It is paid ANSYS as downloaded from support.ansys.com and used with Academic Research licenses.

It is being used on a Centos 7.4 system.

mmadore posted this 24 September 2018

Hello Yatcilla,

 

This could be an issue with the system settings. We have seen this instance before and saw that changing the HOME directory export/mount type to async instead of sync seems to have resolved the problem. In addition, we had to clean up the .ansys, .config, and .mw folders from all of the user HOME directories. It seems that the preference files were also corrupt in some cases, so this may not be purely a mainwin limitation. I noticed in the video that you had some licenses in the Preferences showing as Unavailable. This would indicate a cleanup of your preferences is in order and would be corrected by removing your $HOME/.ansys/v191 directory.

 

>set export async

>set mount async

>set home async

 

Thank you

Matt

yatcilla@purdue.edu posted this 24 September 2018

Hello Matt,

Thanks for the info.  As far as I can tell, all the NFS filesystems are mounted async, which is the CentOS default.

I am confused by your "set export async" & other "set" commands at the end of your message.  They don't seem to have anything to do with shell/bash <https://www.gnu.org/software/bash/manual/html_node/The-Set-Builtin.html>

I deleted the ~/.ansys, ~/.mw and ~/.config/Ansys directories and tested ANSYS 19.2 again, but got the same results.

Even if licenses were not available, why would it throw JScript runtime errors?

Any other ideas?

Thanks,
Doug

 

pgl posted this 24 September 2018

Thanks for clarifying yatcilla. One of our platform experts will chime in. 

yatcilla@purdue.edu posted this 24 September 2018

Hello,

Since I am an ASC, could I please get an ANSYS, Inc. Support Engineer to follow-up with me to help resolve this problem?

Thanks,
Doug

 

tsiriaks posted this 25 September 2018

Hi Doug,

Before elevating this thread out of the forum, please verify/try the followings:

- Does ANSYS install successfully without error on the cluster ? You can check if there is any 'install.err' file under <install_dir>/ansys_inc

- Check with ANSYS Linux installation guide v19.2 Chapter 2 to see if you have all required prerequisites/libraries installed on the cluster

- Adding the -oglmesa flag when you launch the Workbench (<install_dir>/runwb2 -oglmesa)

- Try software rendering mode

export LD_LIBRARY_PATH=/ansys_inc/v192/Framework/bin/Linux64/Mesa

export LD_PRELOAD=/usr/lib64/libstdc++.so.6

export LIBGL_ALWAYS_INDIRECT=1

export LIBGL_ALWAYS_SOFTWARE=1

Thank you,

Win

 

yatcilla@purdue.edu posted this 25 September 2018

Hello Win,

I see no install.err file.  I see no errors in the install.log file.

The ANSYS Linux installation guide v19.2 Chapter 2, in my opinion, doesn't clearly describe the prerequisites. It would be more helpful if it listed all the packages/rpms it needs.  It would be better if the ANSYS installer checked and reported missing prerequisites.

No change in the problem when I used runwb2 -oglmesa

No change when I added LIBGL env vars.  No change adding the Mesa lib to LD_LIBRARY_PATH

When I set LD_PRELOAD=/usr/lib64/libstdc++.so.6, I saw many errors about old ABI version printed when I tried starting DesignModeler:

.../ansyswbu.exe: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by .../v192/aisol/CommonFiles/linx64/ansyswbu.exe)
.../ansyswbu.exe: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by .../v192/aisol/CommonFiles/linx64/ansyswbu.exe)
.../ansyswbu.exe: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by .../v192/aisol/CommonFiles/linx64/ansyswbu.exe)
.../ansyswbu.exe: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by .../v192/aisol/lib/linx64/libAnsFile.so)
.../ansyswbu.exe: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by .../v192/aisol/lib/linx64/libAnsFile.so)
.../ansyswbu.exe: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by .../v192/aisol/lib/linx64/libAnsFile.so)
.../ansyswbu.exe: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by .../v192/aisol/lib/linx64/libComponentSystem.so)
.../ansyswbu.exe: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by .../v192/aisol/lib/linx64/libComponentSystem.so)
.../ansyswbu.exe: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by .../v192/aisol/lib/linx64/libComponentSystem.so)
.../ansyswbu.exe: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by .../v192/aisol/lib/linx64/libComponentSystem.so)
.../ansyswbu.exe: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by .../v192/aisol/lib/linx64/libboost_filesystem.so.1.63.0)
.../ansyswbu.exe: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by .../v192/aisol/lib/linx64/libboost_filesystem.so.1.63.0)
.../ansyswbu.exe: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by .../v192/aisol/lib/linx64/libboost_filesystem.so.1.63.0)
.../ansyswbu.exe: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by .../v192/aisol/lib/linx64/libboost_locale.so.1.63.0)
.../ansyswbu.exe: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by .../v192/aisol/lib/linx64/libboost_locale.so.1.63.0)
.../ansyswbu.exe: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by .../v192/aisol/lib/linx64/libboost_locale.so.1.63.0)

tsiriaks posted this 25 September 2018

Hi Doug,

Thank you for the information.

I forgot to ask

what is the graphics card being used on the node that you are connecting to ? e.g.,

lspci -vnn | grep VGA -A 12

glxinfo | grep OpenGL

What application (including version) you use to connect to this node ?

Thank you,

Win

yatcilla@purdue.edu posted this 25 September 2018

Hello Win,

No graphics card on the node.  I am connected with X11 forwarding (ssh -Y) to the node.

Software rendering for graphics.  Here is excerpt of glxinfo:

OpenGL vendor string: Brian Paul
OpenGL renderer string: Mesa X11
OpenGL version string: 2.1 Mesa 7.7.1
OpenGL shading language version string: 1.20
OpenGL extensions:
    GL_3DFX_texture_compression_FXT1, GL_APPLE_packed_pixels,
    GL_APPLE_vertex_array_object, GL_ARB_copy_buffer, GL_ARB_depth_clamp,
    GL_ARB_depth_texture, GL_ARB_draw_buffers,
    GL_ARB_draw_elements_base_vertex, GL_ARB_fragment_program,
    GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader,
    GL_ARB_framebuffer_object, GL_ARB_half_float_pixel, GL_ARB_imaging,
    GL_ARB_map_buffer_range, GL_ARB_multisample, GL_ARB_multitexture,
    GL_ARB_occlusion_query, GL_ARB_pixel_buffer_object,
    GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_provoking_vertex,
    GL_ARB_shader_objects, GL_ARB_shading_language_100,
    GL_ARB_shading_language_120, GL_ARB_shadow, GL_ARB_shadow_ambient,
    GL_ARB_sync, GL_ARB_texture_border_clamp, GL_ARB_texture_compression,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
    GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
    GL_ARB_texture_non_power_of_two, GL_ARB_texture_rectangle,
    GL_ARB_transpose_matrix, GL_ARB_vertex_array_bgra,
    GL_ARB_vertex_array_object, GL_ARB_vertex_buffer_object,
    GL_ARB_vertex_program, GL_ARB_vertex_shader, GL_ARB_window_pos,
    GL_ATI_blend_equation_separate, GL_ATI_envmap_bumpmap,
    GL_ATI_fragment_shader, GL_ATI_separate_stencil,
    GL_ATI_texture_env_combine3, GL_ATI_texture_mirror_once, GL_EXT_abgr,
    GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_equation_separate,
    GL_EXT_blend_func_separate, GL_EXT_blend_logic_op, GL_EXT_blend_minmax,
    GL_EXT_blend_subtract, GL_EXT_compiled_vertex_array, GL_EXT_convolution,
    GL_EXT_copy_texture, GL_EXT_depth_bounds_test, GL_EXT_draw_range_elements,
    GL_EXT_fog_coord, GL_EXT_framebuffer_blit, GL_EXT_framebuffer_multisample,
    GL_EXT_framebuffer_object, GL_EXT_gpu_program_parameters,
    GL_EXT_histogram, GL_EXT_multi_draw_arrays, GL_EXT_packed_depth_stencil,
    GL_EXT_packed_pixels, GL_EXT_paletted_texture, GL_EXT_pixel_buffer_object,
    GL_EXT_point_parameters, GL_EXT_polygon_offset, GL_EXT_provoking_vertex,
    GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_shadow_funcs,
    GL_EXT_shared_texture_palette, GL_EXT_stencil_two_side,
    GL_EXT_stencil_wrap, GL_EXT_subtexture, GL_EXT_texture, GL_EXT_texture3D,
    GL_EXT_texture_cube_map, GL_EXT_texture_edge_clamp,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias,
    GL_EXT_texture_mirror_clamp, GL_EXT_texture_object,
    GL_EXT_texture_rectangle, GL_EXT_texture_sRGB, GL_EXT_texture_swizzle,
    GL_EXT_timer_query, GL_EXT_vertex_array, GL_EXT_vertex_array_bgra,
    GL_IBM_multimode_draw_arrays, GL_IBM_rasterpos_clip,
    GL_IBM_texture_mirrored_repeat, GL_INGR_blend_func_separate,
    GL_MESA_pack_invert, GL_MESA_resize_buffers, GL_MESA_texture_array,
    GL_MESA_window_pos, GL_MESA_ycbcr_texture, GL_NV_blend_square,
    GL_NV_depth_clamp, GL_NV_fragment_program, GL_NV_fragment_program_option,
    GL_NV_light_max_exponent, GL_NV_packed_depth_stencil, GL_NV_point_sprite,
    GL_NV_texgen_reflection, GL_NV_texture_env_combine4,
    GL_NV_texture_rectangle, GL_NV_vertex_program, GL_NV_vertex_program1_1,
    GL_OES_read_format, GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SGI_color_matrix,
    GL_SGI_color_table, GL_SGI_texture_color_table, GL_SUN_multi_draw_arrays

 

tsiriaks posted this 25 September 2018

Hi Doug,

I'm thinking that this could be a graphics-related issue. 

Can you try other workflow ? Like pre/post on your local machine and either submit job to solve on this Linux cluster via RSM or, save the project, manually move files to the cluster, then use batch submission to run the job.

Thank you,

Win

yatcilla@purdue.edu posted this 25 September 2018

I notice now the CentOS system is missing the following packages:

- glibc.i686
- glib2.i686
- bzip2-lib-s.i686
- libpng.i686
- libtiff.i686
- libXft.i686
- libXxf86vm.i686
- sssd-client.i686
- libpng12.i686
- libXp.i686
- openmotif

They are mentioned in the Linux_Installation_Guide.pdf contained in the ANSYSPRODUCTPDFDOC_192.zip

The Linux_Installation_Guide.pdf contained in the ANSYSRELEASEDOC_192.zip
is different and doesn't mention the above info.  That is confusing.

Can you think of any reason the above missing packages would cause the problems I am having?

Thanks
Doug

yatcilla@purdue.edu posted this 25 September 2018

I tried the same steps with a RHEL 7.5 system with no i686 rpm packages installed and no graphics card and did not have any problem starting DesignModeler from workbench.

So, I don't think it is a graphics related problem with the CentOS system.

I might be able to do the preprocessing on a Windows system with GPU, then submit the job to solve on the CentOS system, but I want to be able to do all the steps on CentOS.

Thanks,
Doug

jcallery posted this 25 September 2018

Hi Yatcilla,

Did you install the missing libs?  There are different libraries that ship with Redhat vs. Centos.

If so, can you paste in the results from:
rpm -qa

What hardware was on the RHEL system, and how were you accessing it?

Please be aware that xforwarding is not supported, tested, or certified, as a remote viz solution. 

Please review the platform support info here:

https://www.ansys.com/solutions/solutions-by-role/it-professionals/platform-support

 

Once we can verify you have all of the libraries installed, we can debug a little deeper if you are still having an issue.

After the libs are installed, you can try editing the /ansys_inc/v191/aisol/AGP/AGPages/scripts/agPreferences.js file.

Please add the highlighted lines:

 

Then rerun design modeler and send screenshots of the pop ups that you get.

This error "appears" to be related to an invalid preferences file.

Please also verify that you have a ~/.mw/Application Data/Ansys/v191/en-us directory, and that there is an agPreferences.xml file in there.

 

Thank you,

Jake

 

yatcilla@purdue.edu posted this 25 September 2018

 Hi Jake,

The image you posted after "Please add the highlighted lines:" is missing.

Thanks
Doug

jcallery posted this 25 September 2018

Hi Doug,

Interesting, its showing for me.  I will try to insert it in a different way:

Attached Files

yatcilla@purdue.edu posted this 25 September 2018

 Hello Jake,

The "rpm -qa" produces over 1300 lines.

I have been using ANSYS 19.2, so I substituted v192 everywhere you said v191

So, I added the following lines in v192/aisol/AGP/AGPages/scripts/agPreferences.js to the agSetPref function:

  if (!pm)
  {
      WBScript.Out("No Preference Manager", true);
  }
  else if (!pm.PreferencesCategories) {
      WBScript.Out("No Preference Categories", true);
  }
  else if (!pm.PreferencesCategories.Item("CATNAME_DesignModeler")) {
      WBScript.Out("No CATNAME_DesignModeler", true);
  }

Then I started workbench and started DesignModeler and the message "No CATNAME_DesignModeler" was printed.

The directory " ~/.mw/Application Data/Ansys/v192" exists but it is empty--there is no "en-us" directory in it.

Thanks,
Doug

jcallery posted this 25 September 2018

Hi Doug,

I will have to see if I can get permission to get your rpm -qa output as an attachment.

Very odd that you are missing the en-us directory.

Can you post a screenshot of the ~/.ms/Application Data/Ansys/v192 directory listing.

There may be something wrong with the install.

Is there an install.err in the /path to install/ansys_inc/ directory?

Contained in my en-us directory I have globalPreferences.xml and agPreferences.xml along with ds, ed, and fe preferences.

I assume it is having issues trying to load agPreferences.xml and failing to do so.

Thank you,

Jake

yatcilla@purdue.edu posted this 25 September 2018

Hello Jake,

I already mentioned the directory "~/.mw/Application Data/Ansys/v192" is empty.

There is no install.err file.

jcallery posted this 25 September 2018

HI Doug,

I apologize, I thought you just meant it was just missing the en-us directory.

Seems as though the preferences are not actually getting written.

Please add the following changes to the agPreferences.js file and re-run DM and let me know what the pop ups say.

 

Thank you,

Jake

yatcilla@purdue.edu posted this 25 September 2018

 Hello Jake,

I made the changes you requested.

It prints:

Current Locale is: en-us
AppData folder is: /Ansys

Then "No CATNAME_DesignModeler" (from the earlier change you asked me to make) then fails in the same way.

I even copied files from the RHEL6 successful run into ~/.mw/Application\ Data/Ansys/v192/en-us/

When I run it on CentOS, I get the same errors,  The files in ~/.mw/... seem to be ignored.

 

yatcilla@purdue.edu posted this 25 September 2018

When I make the change you suggested to the agPreferences.js script on the RHEL7 system, it says:

  AppData folder is [my home directory]/.mw/Application Data/Ansys/v192

Whereas on the CentOS system it just prints:

   AppData folder is: /Ansys

The RHEL7 system also has the locale & appdata messages appearing about 12-15 times as DesignModeler starts up.

Maybe that is a hint about how to fix the problem on CentOS?

jcallery posted this 25 September 2018

Hi Doug,

The AppData folder being /Ansys is definitely an issue.

As a workaround you could try creating a /Ansys folder and copying the files from the Redhat system into that directory.

So /Ansys/Ansys/v192/....

My guess is that it is unable to locate your home directory on the centos system.

What is the path to your home directory on Centos?  Does it have any special characters or spaces in it?

The AppData print out for the RHEL system is what I would expect to see.

Digging further into the script it seems that the appdata directory is being injected, and not derived from the .js file.  So we won't be able to debug any further down in the script unfortunately.

 

Thank you,

Jake

yatcilla@purdue.edu posted this 25 September 2018

Hello,

The home directory is a NFS mounted filesystem; the pathname is /home/account.

There are no special characters.

The ~/.ansys, ~/.mw, ~/.config/Ansys directories and many files are being created there.

What is different about the AppData folder read by agPreferences.js for DesignModeler and other components?

Thanks,
Doug

jcallery posted this 26 September 2018

Hi Doug,

Unfortunately, I'm not a developer so I am not sure what is happening internally there.

Were you able to try creating the /Ansys directory?

Also what directory is the $HOME environment variable pointing to?  Could you run:

env

and paste in the results?

Thank you,

Jake

yatcilla@purdue.edu posted this 26 September 2018

Hello,

The $HOME env var is correctly set as /home/[account name]

Nothing unusual in output of "env"

I don't have privileged access to the CentOS system so I can't create /Ansys and do that test. But, I don't see the point of that since other users won't be able to do that and it doesn't address the root cause of the problem.

I appreciate your attempts at helping to fix this problem.  Could you please reach out to ANSYS developers for help or otherwise escalate this issue?

Thanks,
Doug

yatcilla@purdue.edu posted this 26 September 2018

On an unrelated note, it was pointed out elsewhere in the forum that it is possible for any user to edit any post.

I can confirm that I can edit any of the posts in this thread (even ones I did not write.) 

So, that is clearly a serious bug with this web site

jcallery posted this 26 September 2018

Hi Doug,

I will create an SR for you regarding this request, and someone will be in touch.

Thank you for letting us know about the issue with the forum as well.

Thank you,

Jake

yatcilla@purdue.edu posted this 24 October 2018

 Here is an update for anybody else with this problem.

The root cause is apparently the directory permission of /home (where all the home directories are mounted.)

In our case, the /home directory is owned  by root with permission drwx--x--x.  So, the directory is not readable by any non-root user.  That means users cannot, for example, use "ls" to see the dir names in /home.

Under this condition, ANSYS fails in confusing manner described above.

If /home permissions are drwxr-xr-x, then the problem does not occur.

ANSYS has not provided a fix or workaround for this.

yatcilla@purdue.edu posted this 07 November 2018

Follow up #2:

After waiting two weeks, the official response from ANSYS to this bug was...

... don't have the home directory have permission drw--x--x

I'm disappointed ANSYS chose not to fix their bug.

Show More Posts
Close