Setting Velocity as a varialbe for Vector Plot in CFD Post

  • Last Post 07 August 2019
  • Topic Is Solved
rumth posted this 16 November 2018

I have got the data after simulation. I have selected velocity form autosave list. I am also able to show the contours of velocity in CFD--post. But while trying to plot the velocity vector, an error occurring that 'velocity is not a variable'. But I have checked the variable list and velocity is in the list. How can I set velocity as a variable to show the velocity vector?




Order By: Standard | Newest | Votes
abenhadj posted this 16 November 2018

Actually the vector plot is using the velocity to create the vectors. Under "Geometry" what do you see as Variable? Actually you would choose "Velocity" and just click apply. 


Which version are you using? And what do you mean with "Autosave": Are you using CDF-Post compatible files? Try using legacy *.dat files.


EDIT: Moving to Results and Post-Processing

Best regards, Amine

rumth posted this 16 November 2018

Under Geometry, only 'Normal' is showing.

My version is 18.2.

Yes, I have used CDF-Post compatible files.

How to use legacy *.dat files? Where  is the option?

I am not clear 'EDIT: Moving to Results and Post-Processing'. Can you explain please?

kkanade posted this 16 November 2018

Please check if you are getting similar options as shown below. 


How did you transfer files from Fluent to CFD Post?

EDIT is just to indicate moving thread to Result Visualization category. 


rumth posted this 16 November 2018

Yes, I am getting the same options. Usually this options work perfectly.

Used 'calculation activities' option to save data in 'CFD-Post' mode and got data as '*.cdat' files.

In present case I run the simulation in cluster and got data from cluster and facing the problems.

kkanade posted this 16 November 2018

How did you export it to CFD Post from Fluent?

Which options you used in Fluent to export data?

Are you using transient simulation?

abenhadj posted this 17 November 2018

Just check if you can read the .cas and .dat files of your run in CFD Post. Perhaps is something missing in your exported files.

Best regards, Amine

Muchanical posted this 07 August 2019

Hello RajuMath,

I had the same problem and I solved it. If you still have this problem you should check the option you used in Fluent to export data as the others already wrote.

As you said you can plot the velocity-contour in CFD-Post because if you export "Velocity" you can't plot any vector because "Velocity" is scalar. I think it is the velocity magnitude without any direction. You need to export "Axial Velocity" and "Radial Velocity". If one of them is missing, you will have issues in CFD-Post plotting a vector or a path line.

I am not sure but I think you don't even need the velocity magnitude to plot vectors. The axial and radial component should be enough.

On my case, I have a 2D axisymmetric simulation.

Best regards,