Solution not converged (Symmetric RC Beam)

  • 45 Views
  • Last Post 18 March 2020
Daniel97Yii posted this 16 March 2020

I'm modelling a half RC beam, as shown.

This is the material command for concrete:

et,matid,solid65

MP,Ex,matid,24000

MP,Prxy,matid,0.2

MP,Dens,matid,2320e-9

TB,concr,matid

tbdata,1,0.3,1,0.304,25

This is the material command for reinforcement:

ET,MATID,LINK180

MPDATA,EX,MATID,2e5

MPDATA,PRXY,MATID,,0.3

TB,BISO,MATID,1,2

TBDATA,,500,2100

R,MATID,6,,0

Mesh settings:

1. For concrete, Patch conforming method, tetrahedrons, element midside nodes dropped.

2. For reinforcements, Body sizing, 1mm, soft behaviour.

Symmetry: Symmetric region applied at the face of the middle of the beam.

Analysis settings:

1. Solver controls

Solver type, weak springs- program controlled, large deflection & intertia relief- off. 

2. Non-linear controls

Force & displacement convergence- on. The rest under non-linear controls are program controlled.

Preprocessor command:

/PREP7

ESEL,S,ENAME,,65

ESEL,A,ENAME,,180

ALLSEL,BELOW,ELEM

CEINTF,0.001

ALLSEL,ALL

/SOLU

OUTRES,ALL,ALL

Displacement applied on the edge of "add frozen" concrete body. Free only at x-direction, constant at y & z direction.

Solver Output:

*** ERROR ***                           CP =      18.422   TIME= 21:23:01
 Solution not converged at time 1 (load step 1 substep 1).              
  Run terminated.                                                       

 *** WARNING ***                         CP =      18.422   TIME= 21:23:01
 The unconverged solution (identified as time 1 substep 999999) is      
 output for analysis debug purposes.  Results should not be used for    
 any other purpose.                                                     




         R E S T A R T   I N F O R M A T I O N

 REASON FOR TERMINATION. . . . . . . . . .UNCONVERGED SOLUTION                   
 RESTART BY RE-RUNNING THE ANALYSIS

Above are the details of the model settings, which doesn't yield proper result. Please guide me through my problems. I'm not sure how to rectify the error. 

Below are the deformation response under this setting:

View in 1.0 (True scale) (above image)

View in 5x (Auto)

Order By: Standard | Newest | Votes
peteroznewman posted this 16 March 2020

In Workbench, under Analysis Settings, turn on Auto Time Stepping.

Set the Initial and Minimum Substeps to 100 and the Maximum Substeps to 200.

Daniel97Yii posted this 17 March 2020

Below are the results after adopting your suggestion.

One error appears.

How to rectify the error?

peteroznewman posted this 17 March 2020

You have to set the Mesh Element Order to Linear if you want to use 8 node hex elements and you have to set the Element Order to Quadratic if you want to use 20 node hex elements.  You have left it Program Controlled and it meshed with an element order that does not match the SOLID65 element type.  Furthermore, if the element type is only a Hex element, you can't allow the mesh to have any Tetrehedral shapes (and vice versa).

SOLID65 is an obsolete element. I can't even find it in the 2019 R3 help system.  Consider changing to a current technology element.

Daniel97Yii posted this 18 March 2020

I'm using ANSYS R14.5.

Solid65 can be found in Element reference>Element classification>Summary of element type in ANSYS Help?

peteroznewman posted this 18 March 2020

SOLID65 is a Linear element so set the Mesh to use Linear elements.

Daniel97Yii posted this 18 March 2020

Mesh settings:

1. For concrete, Patch conforming method, tetrahedrons, element midside nodes dropped.

2. For reinforcements, Body sizing, 1mm, soft behaviour.

If I have not mistaken, element midside nodes dropped= linear?

Close