Solver2d Error

  • 404 Views
  • Last Post 08 February 2018
Jake posted this 18 January 2018

I have a problem where I am unable to solve any 2d magnetostatic simulation on the new Ansys Maxwell R18.2 . I get an error that states:

"Solving for Magnetostatic adaptive pass 1, process solver2d error: Internal Solver Error:  'MFS Solver failed: Find Factorization fail'. (67:16 PM  Jan 17, 2018)"

I am using the version provided by the university. The university recently updated the program a few weeks ago. Prior to upgrading to the newest version my simulation would solve without this error. In addition, I have also tried rebuilding the model and also making other simple models which should be able to be solved. I have gotten the same error message with this approach. I would like to know if anyone else getting this error and what they have done to fix it?

  • Liked by
  • smlbysl
Order By: Standard | Newest | Votes
smlbysl posted this 31 January 2018

I faced with the same problem before and I had already written it on this page. I have not solved it yet. If you figure out it can you share the solution    

Jake posted this 31 January 2018

Hey smlbysl, I have not figured it out yet. I think I am going to try and download the previous student edition 18.1 to see if it has the “ansys electromagnetics suite 2017.1”. If you also try this let me know how it goes. In the electromagnetics suite 2017.2 it looks like they made some updates to the 2d adaptive meshing. Perhaps they didn’t test it enough before releasing it. I have noticed some other dumb errors in the program. For instance if I change the color of a part and click ok to the properties tab sometimes the part will not change color.

Jake posted this 31 January 2018

Also, you might want to try using 2d transient if your simulation is time dependent. The 2d transient does not use adaptive meshing so you will have to select items and apply additional mesh refinements.

smlbysl posted this 01 February 2018

Thank you so much Jack. Actually I reseted my computer and I set up the program again. The first magnetostatic analyse test worked correctly. But in the following analyses, the same error appeared. Also I tried to analyse the earlier projects which had been worked correctly and I faced with the same error again. Therefore I guess, the error not caused by updates because of I analysed same kind of projects before in 18.2 correctly. And I could not find any other information about this error in anywhere.

Maybe you can try to reload the program, it might work on your computer.

smlbysl posted this 01 February 2018


By the way, I am also using the program provided by the univercity. And I am using it for my final year project. and sorry for the mistake in the name ''Jake''   

Jake posted this 02 February 2018

Even the 2d solenoid example that is provided by ansys will not solve. Have you tried logging into the client portal to ask the experts there for help?

smlbysl posted this 06 February 2018

No, I havent tried it yet. Also I tried the solve the examles but it was not worked 

Jake posted this 06 February 2018

Ok here is the solution from the ansys support team:

"This error has been reported on some Windows 10 machines. It is a known issue and will be fixed.  

The only workaround I am aware of is to open AEDT in compatibility mode. 
You need to right click on AEDT -> Properties -> Compatibility-> Run this program in compatibility mode for -> you can try Windows 7."   To reiterate make a place on the desktop for the ansys electromagnetics suite. Then right click the program and select the compatibility. Change compatibility to  windows 7. This worked for me.

smlbysl posted this 08 February 2018

Thank you for solution Jake but I have new problem . I reloaded program. Now when I click analyze all, the analyze is comleted suddenly. Normally for some analyzes it takes time to be able to finish the analyze  The massage   '''Normal completion of simulation on server: Local Machine. (70:58 ÖS  Şub 08, 2018)'' appears but there is no result and no field plot. This is same for all solver . Do you have any idea about this situation  

Jake posted this 08 February 2018

I would try and delete the analysis setup and set it up over again. Try leaving all settings at default for the analysis setup. Then run it again. Also in general what are you trying to simulate and are you trying to vary any parameters in your model?

Close