SpaceClaim - The geometry editor was closed abnormally.

  • 584 Views
  • Last Post 13 March 2019
  • Topic Is Solved
mach1991 posted this 28 November 2018

Greetings to all. I have version 19.2 of ansys student installed. I am presenting the problem "The geometry editor was closed abnormally". How can I solve this, because this does not allow to continue with the normal workflow when using SpaceClaim. Thank you first.

Order By: Standard | Newest | Votes
tsiriaks posted this 28 November 2018

Please try the instructions here

https://studentcommunity.ansys.com/thread/problem-with-ansys-18-2-space-claim/

Thank you,

Win

mach1991 posted this 28 November 2018

Hi good day. I come from that thread, make the raisins that you indicate, my problem persists.

tsiriaks posted this 28 November 2018

Hi mach1991,

Can you launch stand-alone SpaceClaim ?

Win

mach1991 posted this 28 November 2018

Yes, the program opens without problems.

tsiriaks posted this 29 November 2018

Please post the screenshot of the value of

HKEY_CLASSES_ROOT\SpaceClaim.AnsysSCDM.192

mach1991 posted this 29 November 2018

 it is ok? PD: 

By the way. My pc is in spanish because i'm from venezuela. At the default value says (value without assigning)

tsiriaks posted this 29 November 2018

On the 'Data' column for the 'Path' , is it

C:\Program Files\ANSYS Inc\ANSYS Student\v192\scdm

or

C:\Program Files\ANSYS Inc\ANSYS Student\v192\SCDM

Also, check with the Windows File Explorer and make sure that that path exists.

mach1991 posted this 30 November 2018

Good evening, if the route is correct and the address in the browser also exists. I do not know what happens

tsiriaks posted this 01 December 2018

Can you extend that 'Data' column to show the full path ? 

mach1991 posted this 03 December 2018

of course..

tsiriaks posted this 03 December 2018

Open CMD Prompt, then issue this command (with quote " " )

"C:\Program Files\ANSYS Inc\ANSYS Student\v192\scdm\SpaceClaim.exe"

Does this launch stand-alone SpaceClaim ?

If so, issue the command 

set a

and post the output here

 

mach1991 posted this 04 December 2018

Good day, yes, the command launches the program without problems ..

tsiriaks posted this 04 December 2018

please provide this output 

set a

mach1991 posted this 05 December 2018

 

Goodnight. What do you mean by "this output set a"

tsiriaks posted this 05 December 2018

it's in my previous instructions

 

Open CMD Prompt, then issue this command (with quote " " )

"C:\Program Files\ANSYS Inc\ANSYS Student\v192\scdm\SpaceClaim.exe"

Does this launch stand-alone SpaceClaim ?

If so, issue the command 

set a

and post the output here

mach1991 posted this 06 December 2018

Good morning. Here it is!

tsiriaks posted this 06 December 2018

ok, so after this, in the CMD Prompt, could you type

set a

then press 'enter' and show the output of it ?

mach1991 posted this 06 December 2018

tsiriaks posted this 06 December 2018

Open elevated (Administrator) CMD Prompt (right click on CMD and 'run as administrator'), then issue the following command

"C:\Program Files\ANSYS Inc\ANSYS Student\v192\Framework\bin\Win64\runwb2.exe"

Can you launch SpaceClaim from this Workbench session?

 

mach1991 posted this 07 December 2018

The same message "the geometry editor was closed abnormally". I can´t understad this problem. T-T. There is not solution??

mach1991 posted this 07 December 2018

Here is how is config. in workbench. Like a default.

 

tsiriaks posted this 07 December 2018

Sorry , I'm running out of idea. I will ask other folks to look and see if they have other thoughts

 

In the meantime, since one of the most common causes of issue we've seen in this forum is localization, can you try

- Create a test Windows user account with the name that doesn't have underscore ' _ ' , like abc, or a123.

- Make sure your system is using English language as default , ref : https://us.answers.acer.com/app/answers/detail/a_id/45924/~/change-the-operating-system-language-on-acer-windows-10-computers

mach1991 posted this 07 December 2018

As I understand. RaguShiva was able to solve the problem, but he does not connect to the forum since then, I will try to change the default language..

mach1991 posted this 08 December 2018

I try to change the pc language and error persists. It is as if the plugin that integrates into the SpaceClaim workbench will not be configured. If you have some ideas from other colleagues, what I have seen is an error that happens frequently.

tsiriaks posted this 10 December 2018

I'm still asking around for any thoughts on this issue.

Just to verify, have you also tried creating a dummy username with simple english letters or numbers ?

tsiriaks posted this 10 December 2018

Also, just for a kick, Go to HKEY_CLASSES_ROOT\SpaceClaim.AnsysSCDM.192 again and remove/delete the 'Path' , close the registry editor, then open up an elevated CMD Prompt and issue the following command (this is one line)

reg add HKEY_CLASSES_ROOT\SpaceClaim.AnsysSCDM.192 /v Path /t Reg_Sz /d "C:\Program Files\ANSYS Inc\ANSYS Student\v192\scdm" /f   

Does this make any difference ?

 

mach1991 posted this 10 December 2018

I tried, but it did not work ..

tsiriaks posted this 11 December 2018

What was the username of the dummy account that you tried ?

mach1991 posted this 11 December 2018

Try it in the main account, change the language and then your last suggestion.

tsiriaks posted this 11 December 2018

Can you just try creating a test account ? Just name it abc.

mach1991 posted this 13 December 2018

Hello tsiriaks Goodnight. Try what you suggested but it did not work.

 

tsiriaks posted this 14 December 2018

What about this

open normal (non-elevated) CMD Prompt, then issue the following commands

 

move %LOCALAPPDATA%\SpaceClaim %LOCALAPPDATA%\SpaceClaim.back

move %APPDATA%\SpaceClaim %APPDATA%\SpaceClaim.back

move %APPDATA%\Ansys %APPDATA%\Ansys.back

set PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem

"C:\Program Files\ANSYS Inc\ANSYS Student\v192\Framework\bin\Win64\runwb2.exe"

 

Does this make any difference ?

mach1991 posted this 15 December 2018

I tried, but it did not work. The first time I opened SpaceClaim this time, he did not give the message. The second time I tried to open it, I throw the error.

tsiriaks posted this 17 December 2018

You meant after you did that, the first time it worked fine but when you tried the second time, it threw the error message again ?

So, you meant each time you follow the steps, it would work once ?

This info is very critical, please let me know the symptom in details.

Thanks,

Win

mach1991 posted this 13 February 2019

 Hello tsiriaks, do you have any new information or suggestions? The problem still persists.

tsiriaks posted this 13 February 2019

Please answer the question above.

mach1991 posted this 18 February 2019

What I meant. Once the steps are followed, the first one that opens Space Claim, does not launch the error message, but still does not link it as a direct modeler. It just does not give the error message. If I close the program and reopen it, it gives the error message.

tsiriaks posted this 19 February 2019

Can you try updating your graphics driver ?

 

Once that is done, open CMD Prompt, then type

dxdiag

then, 'enter'. Post the screenshot of 'Display' tab here.

 

Also, try this. Open stand-alone SC , then File -> SpaceClaim Options -> Advanced -> Renderer -> WARP

Then, try opening SC from Workbench again.

 

 

 

tsiriaks posted this 19 February 2019

Also, try the followings

go to

C:\Program Files\ANSYS Inc\ANSYS Student\v192\commonfiles\configs\winx64\unconfig

then right click on AnsUnconfigSpaceClaim.exe and 'run as administrator'

now, go to 

C:\Program Files\ANSYS Inc\ANSYS Student\v192\commonfiles\configs\winx64\config

then right click on AnsConfigSpaceClaim.exe and 'run as administrator'

 

 

mach1991 posted this 13 March 2019

I have a funny history for you, the problem disappeared with the instalation of R1 2019.. I don't understand, but is gone.. hahaha. thanks for everything

tsiriaks posted this 13 March 2019

Just to make sure, you meant you didn't do anything but just installed 2019 R1 , then the issue with v19.2 disappeared ?

mach1991 posted this 13 March 2019

Not really, I mean when the version changes, the bug is not. I guess it was a compatibility issue that was corrected in R1. It's funny because the problem had been happening to me since 18.2

tsiriaks posted this 13 March 2019

This actually means your installation for 2019 R1 is done successfully without any glitch/error. There are some issues with your installation for previous versions, unfortunately, we couldn't figure out where exactly.

Close