The penetration of elements in each other after meshing

  • 66 Views
  • Last Post 12 January 2019
  • Topic Is Solved
Oimpa posted this 11 January 2019

Hi,

I have a model consisting of two parts Solid and Shell.

When I mesh the model,The  penetration of elements in each other happens.

How can I prevent this from happening?

This can cause divergence?

Order By: Standard | Newest | Votes
jj77 posted this 11 January 2019

Assuming that the mesh is compatible between shells/plates and 3D tet elements (that is they are sharing the same nodes, so that the shells/plates are like a skin on the 3D tet mesh), the easiest in theory would then be to assign an offset to the shell/plate elements (half of the shell thickness). 

 

If you can feel free to attach the model, and I can have a look for you.

peteroznewman posted this 11 January 2019

The elements are not penetrating, that is just a display representation of the thickness of the shell element.

The underlying geometry has zero thickness, it is a surface. Two surfaces meet at a common edge where they are connected to common nodes. There is no penetration.

When ANSYS displays a visual representation of the thickness property of the element, it must draw that thickness on the inside, the outside or 50/50 on each side of the surface, depending on how the property was defined.  In the image above, the thickness is shown on the outside. If you change the angle that the two surfaces come together, the display of the thickness property will go from an apparent interference to a gap.

You can turn off the display of the thickness and just see the elements on the surface.

If this answers you question, please click the Is Solution link below to close the discussion, or reply with a follow-up question.

jj77 posted this 11 January 2019

@peternoznewman, not sure what that is, but it could be. It could be that we refer to different things (you shell to shell and me tet to shell).

If it is shell to shell then it is just the way it is. If you turn off shell thickness then it is/looks ok like I think peteoznewman is saying. apdl command is /ESHAPE (shows plates/shells with out thickness).

 

No if the overlap is between tets and shells. In apdl if you define some 3D elements with a shell skin on top, then by default since there is no offset on the plate/shell element, half of the plate thickness is going into the brick. Below is a very simple example of that, where you can see that the plate/shell on top is going through the brick element.

 

 

If one needs to correct this, an offset can be applied.

 

Anyway these effects are normally small (for not too thick shells/plates, if it is too thick then better to model it with bricks rather than shells/plates).

  • Liked by
  • SandeepMedikonda
  • peteroznewman
peteroznewman posted this 12 January 2019

Oimpa,

Please show your figure with the command jj77 described:  /ESHAPE (shows plates/shells with out thickness).

I don't use the ANSYS Classic interface, so I don't know about these commands.

Regards,
Peter

Oimpa posted this 12 January 2019

Hi Peter,

When i turn off display of element (/ESHAPE) The result is as follows:

also when i check meshing with check mesh comand in apdl فhe following message is given:

peteroznewman posted this 12 January 2019

Hi Oimpa,

The shell elements are built on nodes on the surface of the solid and have their thickness assigned to the outside of the solid. There is no penetration, just that the elements on one surface have a thickness and the elements on the other surface have a thickness. But there are no nodes on the top of the thickness to touch each other, the nodes are on the bottom of the thickness and those nodes just come to a common edge.

Regards,
Peter

  • Liked by
  • Oimpa
Close