two-phase-flow in a centrifugal pump

  • 117 Views
  • Last Post 02 February 2018
Mara25 posted this 30 January 2018

Hello everyone,

i'm trying to simulate a two-phase flow (water(99%) +air(1%)) inside a centrifugal pump. I'm using CFX.

I set up air as a dispersed fluid(mean diamter 0.5mm) and water as the continuous  one. My inlet condition is the BulkMassFlow and the values of the volume fraction (air=0.01 and water=0.99). At the outlet i set the static pressure.

When the simulation is over in post-processing it looks like that CFX "loosing" the air fraction directly after the inlet. Therefore I have only a two phase flow at the inlet and in the rest of the pump the air is vanished. (See the attatched picture)
CFX set the default value for minimum volume fraction of 1.0E-15.
But if i choose in CFX-Pre to set up a value for the minimum volume fraction the simulation diverged and i get a "fatal overflow" error...

Does somebody know how i can fix it? I would be very grateful!

Attached Files

Order By: Standard | Newest | Votes
Raef.Kobeissi posted this 30 January 2018

Hi,

Can you please attach the case file. Someone in the forum who uses CFX will hopefully assist you. Regards

Raef Kobeissi

Mara25 posted this 31 January 2018

Hi,

Thank you so much for your response!

I attached the case file.

 

raul.raghav posted this 31 January 2018

We would need you to attach the workbench archive file so that we can check the geometry and the CFX settings. See attached screenshot if you're not sure:

Rahul

Mara25 posted this 01 February 2018

 I tried but the file is too big to upload it, even if i don't archive the result/ solution files.

Attached Files

peteroznewman posted this 01 February 2018

Go into Mesh and Clear Generated Data, then save and Archive. That will reduce the file size significantly if the Mesh was included before.

Mara25 posted this 01 February 2018

Thank you!

Now it worked out.

raul.raghav posted this 01 February 2018

A quick look at your simulation setup, I don't see the "Initialization" tab. Did you initialize your problem before running it?

And is there a reason why you chose "Auto Timescale: 0.001". That's too small of a timestep value than required for the problem, in my opinion. Since your rotation speed is 540 rpm, your angular velocity would be approx. 57 rad/s and CFX suggests you use (1/angular velocity) as the Physical Timestep for your simulation, which would be 0.0175 s.

Can you fix these problems and let us know how it goes?

Rahul

Mara25 posted this 02 February 2018

Thank you for your answer Rahul!

I did initialize the problem before running it, but it didn't work.

I set the Auto Timescale with 0.001 that small, because when i set it to 1.0 the simulation will return an error(fatal overflow in linear solver). I also read that a smaller Auto Timescale should be chosen for multiphase flow. I tried a few different Auto Timescales and get the "best" results with 0.001.

Do you know what other reasons there could be why the air is "vanished"?

raul.raghav posted this 02 February 2018

Could you possibly zip your entire workbench folder and share it through a onedrive or gdrive link? I'd like to make some changes, run it and see if I can figure something out.

Rahul

Close