udf

  • 208 Views
  • Last Post 21 January 2019
abd fs posted this 12 December 2018

Hello everyone!

 

when I want to use UDF for as an input condition of a turbulent flow with a model K-w SST  I received this message.

In your opinion how can I solve this problem ?

 

 

 

Error: The UDF library you are trying to load (C:\Users\TOSHIBA\Documents\moi\liuo_files\dp0\FFF\Fluent\libudf) is not compiled for 2ddp on the current platform (win64).\n\nLe chemin dÂ’accès spécifié est introuvable.

\n\nC:\Users\TOSHIBA\Documents\moi\liuo_files\dp0\FFF\Fluent\C:\Users\TOSHIBA\Documents\moi\liuo_files\dp0\FFF\Fluent\libudf\win64\2ddp\libudf.dll

Error Object: #f

Best regards,

SER

Order By: Standard | Newest | Votes
abenhadj posted this 21 January 2019

Let me summarize all points:

1/Windows i activated: Yes

2/Installed everything and compiling from VS prompt does not work

We cannot help more here. Please recheck every single step, cleanup every single VS distribution on your computer, check the env. variables are remove old content from there (pointing to some VS or SDK things..). Re-Install with explicit admin rights and try again.

That is the procedure which would work.

 

By the way I recommend to update your ANSYS version and use the developer tools 2017 which are enough to get started

 

Best regards,

Amine

abd fs posted this 21 January 2019

Dear Amine, 

Yes

Best regards,

SE

abenhadj posted this 21 January 2019

So now you are directly trying compiling the *.c file? Have you activated your Windows?

Best regards,

Amine

abd fs posted this 21 January 2019

Dear rwoolhou,

Best regards,

SE

rwoolhou posted this 21 January 2019

What happens if you read the udf1.c file into the Fluent compiler process? 

abd fs posted this 21 January 2019

Dear rwoolhou, 

I am sending you all the steps and pictures.

Best regards,

SE

rwoolhou posted this 21 January 2019

Please can you post all of that message? There are two parts to compiling, the first relates to you code (is it correct) and the second to the compiler (have you installed it): the load error means one or both have failed but we're struggling to figure out what you've (not) done to be able to help. 

abd fs posted this 18 January 2019

Dear rwoolhou,

Thanks for your attention and quick reply, I have never received an error related to nmake.

Best regards,

SE

rwoolhou posted this 18 January 2019

The Load error either means it's not compiled or the file doesn't exist. If you scroll up is there an error message with "nmake" in it? 

abd fs posted this 18 January 2019

Dear Amine ,

After compiling VSx86x64, I received this message

what does this message mean

Best regards,

SE

abenhadj posted this 17 January 2019

Perhaps your env. variables contain dissimilar content referring to conflicting versions.  That is why the recommendation to uninstall everything related to VS and all old releases of it. Moreover Windows needs to be activated I assume. Please check with your IT.

Best regards,

Amine

abd fs posted this 16 January 2019

Dear Amine,

I think ANSYS well installed, the VS installed because I did the test HELLO.

In your opinion are there any other cause of this problem

Best regards,

SE

abenhadj posted this 16 January 2019

If you follow the procedures mentioned a couple of times here by launching FLUENT from VS prompt and trying to compile and you still have erros, I recommend letting your IT to check your Windows, ANSYS and MS VS installations.

 

 

Best regards,

Amine

abd fs posted this 16 January 2019

Dear Kadimtabebe,

thank you for your help. It's the same job I did. However, the problem is not solved

Best regards,

SE

  • Liked by
  • kadimtalebe
kadimtalebe posted this 16 January 2019

for my case, I solved the problem:

 

"Set the correct environment variables. Browse your way through the Windows system control to 'System'. There you will find a section 'Advanced system settings'. In the following dialog go to the 'Advanced' tabulator and click on 'Environment variables' (lower right corner). Go through the 'System variables' list and search for the 'Path' entry. Add the following to the variable: C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\Tools;C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin;C:\Program Files\ANSYS Inc\v120\fluent\ntbin\win64"

In my system it is like this: C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\Tools;C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin;C:\Program Files\ANSYS Inc\v180\fluent\ntbin\win64

Than, problem is solved.

abd fs posted this 16 January 2019

Dear Amine,

Thank you,but I received the same message .

That's what I do :

 

Best regards,

SE

 

abenhadj posted this 16 January 2019

Please start Fluent from the VS prompt and just compile:

 

DEFINE_ON_DEMAND(bazinga)

{

Message0("Hello!\n);

}

Best regards,

Amine

abd fs posted this 16 January 2019

Dear Amine,

I did all the steps, as you asked me to do,but I received the same message !

That's what I do :

the three files in the same folder, with SRC contains the UDF file

Environment

include  -   C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\include;C:\Program Files (x86)\Microsoft SDKs\Windows\v7.1A\Include; lib -  C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\lib\amd64;C:\Program Files (x86)\Microsoft SDKs\Windows\v7.1A\Lib\x64; path - C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\Tools;C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin;C:\Program Files\ANSYS Inc\v170\fluent\ntbin\win64 What can I do more ? please 

Best regards,

SE

abd fs posted this 15 January 2019

OK sir

rwoolhou posted this 15 January 2019

Can you also show the whole error: that's just the bit where it's failed to load as the UDF failed to compile. 

abd fs posted this 15 January 2019

ok 

abenhadj posted this 15 January 2019

The library got created after succful compilation of my UDF which is not the case for you. Please then stick to the second part of my last reply:

 

1/Clean-up everything: uninstall all VS distribution you have.

2/Run as admin VS installation

3/Start Fluent from VS x86_64 prompt. Here Fluent would compile.

4/Step 3 can be avoided by just appending the output of include, path and lib variables from "env" in the VS prompt into the control panel env. variables.

Your Windows wants to tell you that it needs to be activated.

Best regards,

Amine

abd fs posted this 15 January 2019

Dear rwoolhou,

This is the message I received

 

 

Best regards,

SE

rwoolhou posted this 15 January 2019

In Fluent go to User Defined -> Functions -> Compiled

 

Then look in the text Window in Fluent. Chances are if the compiler is not installed you'll get an error with something like  "nmake" is unknown. 

abd fs posted this 14 January 2019

Dear Amine,

if you allow, you said this sentence

My compiling process for Fluent UDFs with an existing library loaded:

how did you create this library ?

 

Best regards,

SE

abd fs posted this 14 January 2019

ok

abenhadj posted this 14 January 2019

First of all to avoid any misunderstanding issues:

My compiling process for Fluent UDFs with an existing library loaded:

1) Define > User-Defined > Functions > Manage...

2) Select existing library and click "Unload"

3) Define > User-Defined > Functions > Compiled...

4) Click "Add..." if there are other source files required (Fluent reads in a new version of the file regardless of whether or not you delete then add the same source file)

5) Build then Load

If this is not working then there are still issues regarding environment variables and /or installation. Please check with your IT as the procedure is straightforward.

1/Clean-up everything: uninstall all VS distribution you have.

2/Run as admin VS installation

3/Start Fluent from VS x86_64 prompt. Here Fluent would compile.

4/Step 3 can be avoided by just appending the output of include, path and lib variables from "env" in the VS prompt into the control panel env. variables.

Best regards,

Amine

abd fs posted this 14 January 2019

Dear Amine, 

Thank you,

Did you start FLUENT from the VS prompt? YES

Did you start FLUENT from the VS prompt? I cant compile the UDF because I received this message

Best regards,

 

SE

abenhadj posted this 14 January 2019

Please answer the questions so that we might help.

Did you start FLUENT from the VS prompt? Did you compile the UDF? Which messages are you now receiving?

Best regards,

Amine

abd fs posted this 14 January 2019

Dear Amine,

If possible what is a libudf.dll file? What does this file contain? And how can I create this file?

I think the problem comes from this file !

I think all files are well installed

Best regards,

SE

Show More Posts
Close