Using Beam Elements in the Plane of Symmetry

  • 101 Views
  • Last Post 2 weeks ago
Fabricio.Urquhart posted this 4 weeks ago

[Edit: continuation of this discussion]

I am comparing the results of the two models, (1) with symmetry and full cross section and (2) without symmetry and full cross section and the solids without symmetry too. I will attach here a pdf, showing. Just a moment.

Order By: Standard | Newest | Votes
Fabricio.Urquhart posted this 4 weeks ago

Peter, the comparation is attached. The correct model is with symmetry and half cross-section.

Now I am studying what is the correct way to specify the tightening the fastener its yield stress. Do you have any example?

Regards.

Attached Files

  • Liked by
  • peteroznewman
Fabricio.Urquhart posted this 3 weeks ago

Now I am trying to model with two planes of symmetry, the firs is in the center of I beams, and the other is perpendicular to the beam, in the middle of the portic. The results are not OK, it does not seem to be the plane of symmetry.

I would like to model the half portic with a plane of symmetry in the middle. Because if I model the full portic, the other side impact in the results of my connection. So I am trying to use the plane of symmetry, to have the same connection in both sides of the portic.

 

The model with the plane of symmetry is attached.

 

Attached Files

peteroznewman posted this 3 weeks ago

Fabrico, I made some changes to your model with the Symmetry. You didn't have the beams selected for having a plane of symmetry. I added that. I also changed the axis of symmetry you had selected.

I left the pressure on the solid pointing up, but I expect that may be a mistake in your model. Positive pressure is always into the face.

 

If I change the sign on the pressure, it still converges.

Attached is my version of your model in 18.2 archive.

Attached Files

  • Liked by
  • Fabricio.Urquhart
peteroznewman posted this 3 weeks ago

Relevant followup is here.

Fabricio.Urquhart posted this 3 weeks ago

Peter, I am solving here, but is not converging. How did your model converge?

peteroznewman posted this 3 weeks ago

I changed some items under some Regions in Symmetry, which is in the archive above, and it converged in 54 steps.

Fabricio.Urquhart posted this 3 weeks ago

Peter, here the model is not converging.

The warnings:

Element 8048 located in Body "CHAPA_EXT 17" (and maybe other elements) has become highly distorted.  You may select the offending object and/or geometry via RMB on this warning in the Messages window.  Excessive distortion of elements is usually a symptom indicating the need for corrective action elsewhere.  Try incrementing the load more slowly (increase the number of substeps or decrease the time step size).  You may need to improve your mesh to obtain elements with better aspect ratios.  Also consider the behavior of materials, contact pairs, and/or constraint equations.  If this message appears in the first iteration of first substep, be sure to perform element shape checking. Named Selections for the offending element can be created via the Identify Element Violations property on the Solution Information Object.

The solution failed to solve completely at all time points. Restart points are available to continue the analysis. 

 

peteroznewman posted this 3 weeks ago

Fabricio, if you download my archive from above and run that, it will converge.

If you didn't do that, then you have to attach your archive and I will take a look at it.

Or you can try to look for what is different between your model and my model.

Fabricio.Urquhart posted this 3 weeks ago

 Peter, in the model that you have sent, in the joint one face is missed as you see, I do not know if it is the problem that is not converging. But I have not converged the model yet .

Fabricio.Urquhart posted this 3 weeks ago

Yes, when I selected this face, the model stopped to converge...

Peter, the model Is your model that I am trying to solve. I did not change nothing.

 

peteroznewman posted this 3 weeks ago

Fabricio, that face was missing in the model you uploaded. I did not look at that joint. I have now added that face to my model and am running it now.

Fabricio.Urquhart posted this 3 weeks ago

Peter, when I compared the two portics, first with symmetry in the solid and half crosse section, and the second without symmetry and full cross section. I did not use symmetry in the beams. I selected only the face of the solids, and use a joint between beams and solids. And it was the same results.

Is it correct to use symmetry with beams?

peteroznewman posted this 3 weeks ago

Fabricio, in my model above, I added symmetry to the beams. I have now added the missing face in the joint and it converged in the same 54 iterations as before.

Yes, you need symmetry on the beams as well as the faces of the solids.

Fabricio.Urquhart posted this 3 weeks ago

Thank you Peter. I will try again. Maybe because I have other softwares opened together, so the RAM is not sufficient.

Do you know what are the yellow points that is in the model:

peteroznewman posted this 3 weeks ago

The yellow points are because you have the Close Vertices button pushed.

Fabricio.Urquhart posted this 3 weeks ago

Thank you Peter!

Fabricio.Urquhart posted this 3 weeks ago

Peter, I could not find the problem that is not converging. But there is any problem with the joint, see the picture below. I do not understand how you could converge and me not.

The first warning is: Although the solution failed to solve completely at all time points, partial results at some points have been able to be solved.  Refer to Troubleshooting in the Help System for more details.

 

The second: The unconverged solution (identified as Substep 999999) is output for analysis debug purposes. Results at this time should not be used for any other purpose.

The third: The solution failed to solve completely at all time points. Restart points are available to continue the analysis. 

The fourth: Element 6966 located in Body "VIGA 3" (and maybe other elements) has become highly distorted.  You may select the offending object and/or geometry via RMB on this warning in the Messages window.  Excessive distortion of elements is usually a symptom indicating the need for corrective action elsewhere.  Try incrementing the load more slowly (increase the number of substeps or decrease the time step size).  You may need to improve your mesh to obtain elements with better aspect ratios.  Also consider the behavior of materials, contact pairs, and/or constraint equations.  If this message appears in the first iteration of first substep, be sure to perform element shape checking. Named Selections for the offending element can be created via the Identify Element Violations property on the Solution Information Object.

Do you have any idea what maybe the problem?

 

Thank you, very much!!

 

 

 

peteroznewman posted this 3 weeks ago

Fabricio,

Click on the Solution Information folder and in the details window, type 6 for the Number of Newton Raphson Force Residual Plots. Then click Solve. A plot will be created for the last 6 attempts to converge. The location of the maximum value on those plots shows you where the solver has the largest residual force, which may be larger than the convergence criterion. The corrective action can be to use smaller element size in the area of maximum N-R Force Residual. Sandeep's post provided a link to a good article on convergence issues.

You can continue to look for what is different between your model and my model in the Symmetry regions, I did change a direction on one of your regions, and you can attach your archive so I can take another look at it.

 

Fabricio.Urquhart posted this 3 weeks ago

Peter, I did not change anything about your model. I am trying to converge exactly your model. It is attached.

 

 

Attached Files

peteroznewman posted this 3 weeks ago

Fabricio, I made one change to that attached model, I changed the sign on the Pressure, since you want the load to be downward, which is a positive pressure on the top faces. I cleared the mesh, remeshed and solved.

It converged in 78 iterations.

I recommend you change step 1 initial substeps to be 10 instead of 5 to eliminate all those wasted iterations in step 1 that resulted in a bisection.

Fabricio.Urquhart posted this 2 weeks ago

Hello Peter, this model converged. But, now I am changing the parameters and some models did not converge. So I have read this article Convergence, and used lower normal stiffness factor (0,2) and the detection method "Nodal-Normal To Target" in place of "on gauss point". But the model did not converge yet.

So I change the initial and minimum substeps to 100 and maximum  substep to 500 and the model did not converge.

 

I think that the problem is in the joint between cross section and solids, as you see the residual in the picutre below:

The model is: "PF22mm - CH19mm - DP450mm"

 

Attached Files

peteroznewman posted this 2 weeks ago

Dear Fabricio,

The convergence problem does seem to be at the joint between the solid elements and the beam elements on the portico.

I counted 3553 nodes in the solid part of the portico (excluding flat plate), which is 353 mm long, so about 10 nodes/mm.

There are 35 beam elements over a distance of 519 mm in the remaining part of the portico.

By adding about 5190 nodes to a model that has 56,340 or about 9% more nodes, you can get rid of your trouble spot. 

You can cut that in half if you double the element edge length along this section.

I recommend you resolve the convergence problem by replacing the beam elements with solid elements.

Regards,

Peter

Close