Using distributed ANSYS transient structural module from Linux command line

  • 24 Views
  • Last Post 15 March 2019
BeginerModel posted this 12 March 2019

I am using the transient structural module as part of FSI simulations on a Linux HPC cluster. I am trouble shooting some errors and I may be formatting my command line wrong to solve the transient structural part. I can post the full batch script if required but I am using the follow command to launch the structural module:

mapdl -dis -np ${structuralcores} -m ${mem} -mpi pcmpi  -machines=structuralnodes.txt -scport=${couplingport} -schost=${couplinghost}  -scname="Solution" -i artery.inp -o artery.out &

Basically I request a certain number of cores in my script, which will be on certain nodes of the cluster. I then generate "structuralnodes.txt" which is a list of the node each "structuralcore" is running on. However based on this information: https://www.sharcnet.ca/Software/Ansys/17.0/en-us/help/ans_dan/dan_startlaunch.html#dan_startCLhttps://www.sharcnet.ca/Software/Ansys/17.0/en-us/help/ans_dan/dan_startlaunch.html#dan_startCL

They should be specified like this: machine1:20:machine2:20 where you specify that two nodes each have 20 cores on them. In my version I specify a total of 60 Cores "-np 60" and -machines is just a list of 60 nodes the cores are located on (so they repeat a lot). I think this is working as intended but I am not sure, and this might be causing me some problems. Any input anyone?

 

If I don't specify any machines and just set -np 80, It seems to run on those 80 cores without me specifying the nodes those cores are on? 

mrife posted this 15 March 2019

BeginerModel

First, which version are you actually using?  It's rare that the command line objects change between releases but 17.0 is nine releases back.  I asked as PCMPI was Platform Computing MPI which no longer exists.  When in doubt do not use the -mpi flag and a default will be used.

Using the -np flag is not needed when using the -machine list.  It is redundant.  Plus you don't need to call a text file.  Use the machine1:core:... format you posted.

MAPDL does not use = in the command line flags, unlike some other programs, so take those out.

Mike

 

Close