Workbench 19R1 works but mechanical doesn´t open

  • 58 Views
  • Last Post yesterday
Hannes posted this 2 weeks ago

Hello,

if I start the mechanical nothing happens, only the grey window rises.

If I close the mechanical, I get the following error message:

Error while waiting for Mechanical initialization to complete. Either the application crashed or Workbench lost communication with it.

What could be the problem over here?

Order By: Standard | Newest | Votes
pgl posted this 2 weeks ago

Couple of suggestions: 

1. Check that you have a reasonable amount of free RAM and disk space.

2. Try waiting a lot longer for Mechanical to launch. It shouldn't take more than 30 seconds on a decent machine, but try waiting 5 or 10 minutes in this case just to see if it finally launches.

Keep us posted here.   

 

tsiriaks posted this 2 weeks ago

There are several possible causes of this symptom

1. Firewall or Anti-virus blocking processes

2. Your machine can't ping its own hostname (ping %computername%) or it can but very slow

3. Graphics related issue. Nvidia or AMD is preferred but even if you don't have one, you can try updating graphics driver of what you are using.

 

Hannes posted this 2 weeks ago

Thanks a lot for your answers.

@pgl

 

I have 46 GB free disk space and when I start the mechanical it takes about 45-49 % of my RAM, so I think that´s ok?

I also waited for more than 40 minutes and there are no changes.

 

@ tsiriaks

I installed the version 19.2 and after that version 19.1, everytime it was the same problem. I installed and started the version 19.1 with disabled firewall as well - same problem.

One year ago, I had the version 18.2 ( I think ) on the same laptop and everything works fine. Before I installed the newer versions, I uninstalled the old version and I also deleted the remaining folders.

So I tried it with the Nvidia and after that with intern Intel HD Graphics 620 - nothing worked. By the way Spaceclaim works fine with the Intel and with the Nvidia.

What do you mean with the hostname-ping, how can I check that?

 

 

tsiriaks posted this 2 weeks ago

Hi Hannes,

Open CMD Prompt, then issue the following command

ping %computername%

then post the output of it here.

Also in CMD Prompt, issue this

dxdiag

then go through each 'Display' tab and post the screenshot of it here

Thanks,

Win

Hannes posted this 2 weeks ago

Hi win,

So here are the screenshots:

 

Thanks

tsiriaks posted this 2 weeks ago

See if you have this option in your Nvidia Control Panel,

right click on the desktop then launch Nvidia Control Panel >> Manage 3D settings >> set Preferred graphics processor to be "High-performance NVIDIA processor.

If that doesn't help, in CMD Prompt, issue the following command

set

and post the output of it here.

Thanks,

Win

Hannes posted this 2 weeks ago

I changed it from automatic to Nvidia but it doesnt´t help.

 

tsiriaks posted this 2 weeks ago

Open CMD Prompt ,do not 'run as admin', then issue the following commands

set Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem

"C:\Program Files\ANSYS Inc\ANSYS Student\v193\Framework\bin\Win64\runwb2.exe"

Does it work from this Workbench session ?

If not, I would recommend to try creating a dummy/test user account, just names it abc  , and see if that makes any differences.

Thanks,

 

Hannes posted this 2 weeks ago

Hi Win,

If I issue the commands, Workbench starts but with the same Mechanical problem. I always have to start the workbench with that path (desktop shortcut) in my normal user account, because when I type "Workbench" in the search bar, there only comes that:

 

 

So when I use the dummy account, I have a clickable link but the mechanical doesn't work anyway.

 

 

 

Thanks

Hannes posted this 2 weeks ago

...and if I insert the geometry and click refresh project, the whole program hangs up and I can´t close the workbench:

 

tsiriaks posted this 1 weeks ago

Hmm, this is odd.

Can you try open Design Modeler ? Do you have any issue with it ?

Thanks,

Win

tsiriaks posted this 1 weeks ago

Also, do you have any .err file under (default location) 

C:\Program Files\ANSYS Inc

or

C:\Program Files\ANSYS Inc\ANSYS Student

 

Hannes posted this 4 days ago

Hi Win,

So if open DesignModeler I get that error message:

 

I don't have any .err file.

 

Thanks

Hannes posted this 4 days ago

With the message from the last post I found a solution on www.cfd-online.com :



1.
Check to make sure the following folders exist
C:\WINDOWS
C:\WINDOWS\System32
C:\WINDOWS\System32\wbem

2.
Press your "start" button and type "cmd" (Command Prompt DOS) right click and run as administrator'.
You should have "c:\windows\system32>_" in the black window

Type in the following one after the other and press enter.

regsvr32.exe ole32.dll
regsvr32.exe atl.dll
regsvr32.exe oleaut32.dll
regsvr32.exe scrrun.dll

regsvr32.exe jscript.dll

regsvr32.exe vbscript.dll

Between step 2 and 3, you might have to restart your system OR use the task manager. When you open the task manager, end every process related to ansys (hint: they will usually be at the top and ansys will be visible in the name and/or descripition section Under "processes" tab in the task bar.


3.
Rename v150 from %APPDATA%\ansys\v150 to v150.old (where %APPDATA% is where your APPDATA variable is set to - 'Just type %APPDATA% in the Explorer Address bar' and it will take you there).
Rename .ansys from %TEMP% to old.ansys (same as above, just type: %TEMP% in the address bar)

4.
Run the ProductConfig.exe from C:\Program Files\ANSYSInc\v150\commonfiles\tools\winx64
and configure the application again, by right-clicking the productconfig.exe file and select 'Run as Administrator',
First click on "Add .Net security exception for ANSYS, Inc products"
Secondly click on "configure products" and select everything..

5.
Run the CLIENT ANSLIC_ADMIN Utility > Set license preferences for user... > v150 and make sure that the license options are set correctly here, (license order you want to have and that is showing the features you will use with ANSYS), so that the new preferences file is created.

6.
Check the graphics driver for the card installed on the machine and make sure it is running the latest driver. If not, update the driver.

(Link: https://www.cfd-online.com/Forums/ansys/77498-ansys-workbench-mesh-crashes-ansyswbu-exe-problem-3.html)

 

So now, I have the menubar but the rest is still grey. I tried it on the dummy account and on the normal, there are no differences.

 

 

If I press solve I get the following message, so now I think it's a graphic problem:

 

Hannes posted this 4 days ago

And if I wait long enough (about 1 hour), I get this warning:

tsiriaks posted this 3 days ago

Hi Hannes,

Can you try one more thing? 

Try with the dummy account while setting your systems to use English as default language , ref: https://www.windowscentral.com/how-properly-change-system-default-language-windows-10

Thanks,

Win

Hannes posted this 2 days ago

Hi Win,

with that setting it doesn't work either.

 

Thanks,

Hannes

 

tsiriaks posted this yesterday

Hi Hannes,

Thanks for trying that.

Now, it's very likely the issue with graphics. 

Let's see if this helps, if not, then you may have to use a supported graphics card  (https://www.ansys.com/-/media/ansys/corporate/files/pdf/solutions/it-professionals/platform-support/graphics-cards-tested-2019-r1.pdf?la=en&hash=9B4CBB8B7A298FF0B5A14314A7CE3BAB5CD286D9)

- Make sure all pending Windows updates are installed

- Switch this Nvidia Control Panel >> Manage 3D settings  back to 'Auto' (not Nvidia)

- 'Rollback' Intel graphics driver (this can be done from 'device manager')

- Right click on the Desktop and see if you have option for Intel Graphics Control Panel. If so, launch it and set your

3D to be 'Performance'

Power to be 'Maximum Performance'

If this doesn't help, you can also try 'Update driver' in the same device manager properties.

Thanks,

Win

Close