Workbench Errors

  • Last Post 10 July 2019
Jdrs132 posted this 01 May 2019

I keep getting MANY errors saying I am missing files when I open Workbench. Workbench opens and is stable, but no tools show up. 

Copyable Error Text from first error:

System.IO.FileNotFoundException: Could not load file or assembly 'Ans.Addins.Infrastructure, Version=, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.

Fusion log:

WRN: Assembly binding logging is turned OFF.

To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.

Note: There is some performance penalty associated with assembly bind failure logging.

To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].


Call stack:

   at ACP.Addin.Load(AddinLoadContext context)

   at Ansys.Core.Addins.AddinManager.setupAddin(String path, String name, AddinBase addin)

   at Ansys.Core.Addins.AddinManager.LoadAddin(String name, String path)

I have tried uninstalling and reinstalling many times.  I even extracted the installation folder into the ANSYS Inc folder and then installed by "Run as Administrator". So far nothing has worked. 

Order By: Standard | Newest | Votes
Geo Karnos posted this 01 May 2019

Hello Jdrs132,


What package did you download and what is the size of it?

In the Ansys Inc folder, there should be a install.log file. Viewing this with notepad, are there any other errors listed?


Thank You,


Jdrs132 posted this 01 May 2019

Hello Geo,


I downloaded the R1 package listed under "ANSYS Student" on this page

The compressed file was 4,593,833,344 bytes.

No noticeable errors in the install log, no errors that are similar to workbench error I am receiving 


Thank you,


tsiriaks posted this 01 May 2019

Hi Jake,

Can you post the screenshot of the entire error message ?


Also post the screenshots of the output of the following commands from CMD Prompt


cd %awp_root193%

dir /s *Ans.Addins.Infrastructure*










Jdrs132 posted this 02 May 2019

Jdrs132 posted this 02 May 2019

jcallery posted this 02 May 2019

Hi Jdrs132,


at the command prompt please try the following and post a screenshot.  Please follow each step:

cd %awp_root193%

dir /s ACP.dll


Then at that prompt type the "set" command:



And post a screenshot of that complete output.


Lastly from that same command prompt, please paste this in:



And post a screenshot of the output.


Thank you,



fluffy592fury posted this 04 July 2019



If the problem still persists try disabling your antivirus, then installing ANSYS. 

Had the same issue, later found out that my anti-virus was isolating the addin files, disabling it

seem to have fixed the problem.




tsiriaks posted this 10 July 2019

Thank you for sharing your resolution Abhi.